Completed -
okie dokie, RDSs have been upgraded as quickly as expected, nothing related seems to have exploded in the time since, so i think we're in the clear, yay
Apr 30, 06:43 UTC
Update -
update: from the AWS console for commercial production:
- April 30, 2025, 16:09 (UTC+10:00) Multi-AZ instance failover completed
- April 30, 2025, 16:09 (UTC+10:00) The RDS instance was modified by customer.
- April 30, 2025, 16:08 (UTC+10:00) DB instance restarted
- April 30, 2025, 16:08 (UTC+10:00) The parameter max_wal_senders was set to a value incompatible with replication. It has been adjusted from 20 to 65.
- April 30, 2025, 16:08 (UTC+10:00) Multi-AZ instance failover started.
- April 30, 2025, 16:01 (UTC+10:00) Applying modification to database instance class
so it looks like that took 2 minutes from the RDS perspective, and we did see some 5XX responses from the Micros API during this time
Apr 30, 06:31 UTC